MDsave.com outage
Incident Report for MDsave
Resolved
This incident has been resolved.
Posted Dec 22, 2021 - 09:05 CST
Update
The issue with our cloud provider has been resolved, and mdsave.com is fully operational again.
Posted Dec 22, 2021 - 09:04 CST
Investigating
Our cloud provider is experiencing issues which is causing mdsave.com to be unaccessible. We are investigating and are working to restore the website as soon as possible.
Posted Dec 22, 2021 - 07:46 CST
This incident affected: Website and Website Hosting Services (AWS EC2 (N. Virginia data center)).