Degraded Phone Support Performance
Incident Report for MDsave
Resolved
Talkdesk, our provider for our phone support services, has resolved the issue as of Mar 28, 16:17 UTC
Posted Mar 28, 2022 - 11:20 CDT
Identified
We are currently experiencing issues with Talkdesk, our provider for our phone support services. Talkdesk has identified the issue and has implemented a solution and is seeing some improvements.

At Mar 28, 16:00 UTC, Talkdesk provided the following update:
Monitoring - Mitigation measures were applied, and we are seeing improvements. We will keep monitoring the situation.

For real time updates from Talkdesk, please see their status page at https://status.talkdesk.com/
Posted Mar 28, 2022 - 11:10 CDT
This incident affected: Phone Support and Customer Support Services (Talkdesk Inbound, Talkdesk Outbound).