Issue Downloading Voucher PDFs and Excel Reports
Incident Report for MDsave
Resolved
This incident has been resolved.
Posted Dec 07, 2021 - 17:00 CST
Identified
Amazon Web Services is currently experiencing issues that are preventing some users from being able to download PDFs and Excel spreadsheet from mdsave.com. Amazon is currently working on fixing the issue (their status is available at https://status.aws.amazon.com/)
Posted Dec 07, 2021 - 12:41 CST
This incident affected: Website.