Slow website performance
Incident Report for MDsave
Resolved
This incident has been resolved.
Posted Aug 21, 2024 - 11:38 CDT
Monitoring
This appears to have been an intermittent issue. We are continuing to monitor in order to identify the underlying cause. Website performance should be stable now.
Posted Aug 21, 2024 - 09:20 CDT
Investigating
The MDsave website is experiencing slow load times and occasional error pages. We're investigating now and will update once we have more information.
Posted Aug 21, 2024 - 09:13 CDT
This incident affected: Website.