Degraded Phone Support Performance
Incident Report for MDsave
Resolved
Talkdesk, our provider for our phone support services, has resolved the issue as of Mar 22, 17:24 UTC.
Posted Mar 22, 2022 - 12:24 CDT
Update
We are currently experiencing issues with Talkdesk , our provider for our phone support services. Talkdesk has identified the issue.

At Mar 22, 16:34 UTC, the provided the following update:
Identified - We are currently investigating a subset of calls not being delivered to agents due to a Talkdesk Telecom Partner incident, Mitigation measures are in progress and business continuity settings have been enabled. We will provide an update in 15 minutes or sooner.

For real time updates from Talkdesk, please see their status page at https://status.talkdesk.com/
Posted Mar 22, 2022 - 11:36 CDT
Identified
We are currently experiencing issues with Talkdesk , our provider for our phone support services.

Talkdesk is currently investigating the issue. For real time updates from Talkdesk, please see their status page at https://status.talkdesk.com/
Posted Mar 22, 2022 - 11:30 CDT
This incident affected: Phone Support.