CareCredit Service Disruption
Incident Report for MDsave
Resolved
CareCredit is no longer experiencing a service disruption.
Posted Apr 20, 2023 - 13:31 CDT
Identified
CareCredit is currently experiencing a service disruption. Currently, we may have issues processing CareCredit transactions due to the service disruption.

Patients can purchase using credit card or Paypal on mdsave.com.
Posted Apr 20, 2023 - 12:18 CDT
This incident affected: Website.