Credit Card Payment Processing Issues
Incident Report for MDsave
Resolved
This incident has been resolved.
Posted Jun 25, 2020 - 12:45 CDT
Monitoring
We have resolved the issue with our payment provider and are now testing to determine if the issue is resolved.
Posted Jun 25, 2020 - 10:08 CDT
Investigating
We are currently investigating an issue that is causing credit credit transactions to be declined.
Posted Jun 25, 2020 - 09:38 CDT
This incident affected: Website.