Degraded Phone Support Performance
Incident Report for MDsave
Resolved
Our phone provider, Talkdesk, has resolved the issue.
Posted Aug 26, 2021 - 17:04 CDT
Identified
We are currently experiencing issues with Talkdesk (https://status.talkdesk.com/), our provider for our phone support services.

At this time, please use the Live Chat feature on the website.
Posted Aug 26, 2021 - 12:39 CDT
This incident affected: Phone Support.