Intermittent Slowness and 504 Errors
Incident Report for MDsave
Resolved
We have implemented a long term fix for the issue and we continue to no longer have issues.
Posted Aug 30, 2023 - 13:04 CDT
Monitoring
The issues causing the intermittent slowness and 504 errors have been identified. We are still closely monitoring the situation, but the site is operating normally currently.
Posted Aug 28, 2023 - 13:58 CDT
Investigating
We are currently investigating an issue that is causing some pages to load slower and occasional 504 errors.
Posted Aug 28, 2023 - 13:25 CDT
This incident affected: Website.