Intermittent Slowness and 504 Errors
Incident Report for MDsave
Resolved
This incident has been resolved.
Posted Sep 20, 2022 - 16:12 CDT
Monitoring
We are no longer experiencing 504 responses and are continuing to monitor the situation.
Posted Sep 20, 2022 - 13:23 CDT
Investigating
We are currently investigating an issue that is causing some pages to load slower and occasional 504 errors.
Posted Sep 20, 2022 - 10:09 CDT
This incident affected: Website.