Intermittent Slowness and 504 Errors
Incident Report for MDsave
Resolved
This incident has been resolved.
Posted Aug 24, 2023 - 12:15 CDT
Monitoring
The issues causing the intermittent slowness and 504 errors have been identified. We are still closely monitoring the situation, but the site is operating normally currently.
Posted Aug 24, 2023 - 09:54 CDT
Investigating
We are currently investigating an issue that is causing some pages to load slower and occasional 504 errors.
Posted Aug 24, 2023 - 09:39 CDT
This incident affected: Website.