Interruption with Credit Card Payments
Incident Report for MDsave
Resolved
The issue with our credit card processor (authorize.net) has been resolved
Posted Jul 28, 2021 - 15:15 CDT
Investigating
Our credit card processor (authorize.net) is currently experiencing an outage that is preventing purchases from being completed on MDsave.com using a credit card.
Posted Jul 28, 2021 - 14:16 CDT
This incident affected: Website.