Site Slowness
Incident Report for MDsave
Resolved
This has been resolved. Please reach out if you continue to experience any website issues.
Posted Jun 04, 2024 - 12:30 CDT
Monitoring
We have implemented a fix to our database and are monitoring ongoing performance.
Posted Jun 04, 2024 - 11:58 CDT
Update
We deployed a fix which helped to temporarily relieve the load on the database.

We are still experiencing slowness on the site, but we have seen a decrease in the number of users experiencing a 504 timeout.

We are continuing to work on a fix.
Posted Jun 04, 2024 - 10:55 CDT
Identified
We are currently experiencing slowness on the site. We are currently working on deploying a fix.
Posted Jun 04, 2024 - 09:00 CDT
This incident affected: Website.