Post Purchase Page
Incident Report for MDsave
Resolved
This incident has been resolved.
Posted Sep 13, 2018 - 11:39 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 13, 2018 - 17:03 CDT
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 13, 2018 - 08:32 CDT
Update
We are continuing to investigate this issue.
Posted Sep 11, 2018 - 09:48 CDT
Investigating
We are currently experiencing an issue and showing “We will be right back” instead of the post-purchase page after completing a purchase. Purchases are still being completed successfully, so please use your browser’s “back” button and navigate to the Vouchers page to view recent transactions.
Posted Sep 11, 2018 - 09:23 CDT
This incident affected: Website.