Credit Card Payment Processing Issues
Incident Report for MDsave
Resolved
This incident has been resolved.
Posted Aug 05, 2020 - 12:00 CDT
Monitoring
We have resolved the issue with our payment provider and are now testing to determine if the issue is resolved.
Posted Aug 05, 2020 - 09:07 CDT
Investigating
We are currently investigating an issue that is causing credit credit transactions to be declined.
Posted Aug 05, 2020 - 08:47 CDT
This incident affected: Website.