Payments with Multiple Credit Cards Do Not Work
Incident Report for MDsave
Resolved
The issue is fixed.
Posted Oct 19, 2017 - 18:01 CDT
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 19, 2017 - 16:21 CDT