Some pages not working on Internet Explorer 11
Incident Report for MDsave
Resolved
This incident has been resolved.
Posted Aug 24, 2018 - 19:42 CDT
Monitoring
We have deployed our solution and are monitoring the results.
Posted Aug 09, 2018 - 17:50 CDT
Identified
We have identified a potential cause of the issue and are implementing a fix. Please continue to call us at (877) 461-2491 if you need assistance making purchases or redeeming vouchers.
Posted Aug 03, 2018 - 13:00 CDT
Investigating
Users of certain versions of Internet Explorer 11 are experiencing errors on certain pages of the website that cause the page to not fully load and prevent clicking on various buttons/forms. We are investigating the issue to determine the cause.

If you are having issues, please try a different web browser if available, or call our support team at (877) 461-2491 to complete purchases or redeem vouchers.
Posted Aug 02, 2018 - 09:53 CDT
This incident affected: Website.